En este grupo En todos

Grupo de Configuración de servidores



servidor web con plataforma moodle

luisa fernanda
Ingenieria en telecomunicaciones unive...
Escrito por Luisa Fernanda Franco Carmona
el 29/09/2010

Buenas noches necesito crear un servidor web con una plataforma educativa (moodle) y a la que se podrá acceder desde internet utilizando una dirección web. Y no tengo ni idea de por donde empezar me pueden brindar un tutorial para dumis o darme alguna idea.


Muchas gracias

Gabriel Goncalves
Málaga, España
Escrito por Gabriel Goncalves
el 07/11/2010

Hola, te puedo ayudar

Escribeme a mi correo :

Thor2100@hotmail. Com

Gabriel

Luisa Fernanda Franco Carmona
Ingenieria en telecomunicaciones unive...
Escrito por Luisa Fernanda Franco Carmona
el 07/11/2010

Hola thor como te encuentras, efectivamente me gustaria saber como debo de realizarlo ya que segui varias guias de internet y aun no me funciona, si me puedes dar alguna idea te lo agradeceria, de casualidad ¡Sabes conectar gns3 con virtualbox en windows?

Muchas gracias

si algo mi correo es fer. 350@hotmail. Com

Jose Palmeros
Ingeniero en desarrollo de software un...
Escrito por Jose Palmeros
el 16/02/2011

/*


Muy bueno eso para dummies.


Aquí algo de ello


Requerimientos

Moodle está desarrollado principalmente en GNU/Linux usando Apache , MySQL y PHP (también conocida como plataforma LAMP), aunque es probado regularmente con PostgreSQL y en los sistemas operativos Windows XP, MacOS X y Netware 6.


Los requerimientos de Moodle son los siguientes:

  • Un servidor web. La mayoría de los usuarios usan Apache , pero Moodle debe funcionar bien en cualquier servidor web que soporte PHP, como el IIS (Internet Information Server) de las plataformas Windows.
  • Una instalación de PHP en funcionamiento (versión 4.3.0 o posterior). PHP 5 está soportado a partir de Moodle 1.4. (tenga cuidado con PHP-Accelerator ya que se han detectado problemas con él. Moodle 2 necesita como mínimo la versión 5.2.8. Si se usa PHP 5. 3, hay que asegurarse que la versión es superior a la 5.3.2
  • Una base de datos: MySQL o PostgreSQL , que están completamente soportadas y recomendadas para su uso con Moodle. MySQL es la elección preferida para mucha gente porque es muy popular, pero hay algunos argumentos a favor de PostgreSQL, especialmente si está planificando instalaciones de grandes dimensiones. MySQL 4.1.16 es la versión mínima para trabajar con Moodle 1. 6 (muchas distribuciones de Linux incorporan versiones más antiguas, así que debe comprobar este extremo). Moodle 2 necesita como mínimo la versión 5.0.25.

La mayoría de los servicios de alojamiento web (hosting) soportan todo esto por defecto. Si ha contratado los servicios de alguno de los pocos servicios de alojamiento web que no soportan estas características, pregúnteles por qué no lo hacen y considere la posibilidad de trasladar su sistema a otro sitio.


Una buena forma de instalarlo es en un servidor Linux, por ejemplo Ubuntu lo trae en sus repositorios.


Fuente:


https://docs.moodle.org/es/Instalaci%C3%B3n_de_moodle


https://docs.moodle.org/es/Instalaci%C3%B3n_AMP