En este grupo En todos

Foro de Excel

Fernando Excel Dudasexcel@hotmail.com
Informatica conde de casal
Escrito por Fernando Excel Dudasexcel@hotmail.com
el 08/03/2010

Hola Armando, ya subo yo el archivo por el, al fin y al cabo ha sido copiar lo que el ha puesto en el post.
.
https://grupos.emagister.com/documento/seleccionar_registros/6610-399492

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 09/03/2010

Iintenta con esto:
=SI(SUMAPRODUCTO(B$2:B$11=B3)*(E$2:E$11="SI "))>0,"VER","")
Tal vez debas cambiar la coma por punto y coma.

Fernando Excel Dudasexcel@hotmail.com
Informatica conde de casal
Escrito por Fernando Excel Dudasexcel@hotmail.com
el 09/03/2010

Hola Armando.
.
=SI(SUMAPRODUCTO(B$2:B$11=B3)*(E$2:E$11="SI "))>0;"VER";"")
.

¡¡¡¡OJO! La formula de Armando esta bien y la mia, pero el mensaje no deja poner otro parentesis aqui:($B2: justo detras del $ van en total 2 parentesis no 1 como se ve aqui.
pero no me da el resultado esperado, te pongo lo que me da:
.

Número de deudor Nombre de deudor REFERENCIA DTOS DTO ERRONEO IDENTIFICAR
3900005 CLIENTE PEPE REF 1 30% NO VER
3900021 CLIENTE ANTONIO REF 1 15% NO VER
3900021 CLIENTE ANTONIO REF 2 10% SI VER
3900021 CLIENTE ANTONIO REF 3 20% NO VER
3900021 CLIENTE ANTONIO REF 8 20% NO
3900022 CLIENTE LUIS REF 15 8% NO
3900022 CLIENTE LUIS REF 2 6% NO VER
3900023 CLIENTE ANDRES REF 2 40% NO VER
3900023 CLIENTE ANDRES REF 4 10% SI VER
3900023 CLIENTE ANDRES REF 5 12% NO

por lo cual no es correcto si pepe que es 1 y tiene un NO ponga ver a Antonio le faltaria un VER, a Luis quitarle un VER y a Andres ponerle un VER.

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 09/03/2010

Fernando, aqui subi el ejemplo:
https://grupos.emagister.com/documento/seleccionar_registros__solucion/6610-400161
Tal vez la falla se deba a espacios en blanco, por eso escribi "SI ", con un espacio posterior, lo mismo sucedio en la columna clientes

Fernando Excel Dudasexcel@hotmail.com
Informatica conde de casal
Escrito por Fernando Excel Dudasexcel@hotmail.com
el 09/03/2010

Armando comprobado y funciona perfectamente.
La razón que no daba esa formula era el tema del espacio posterior al SI, ya que cuando copie los datos dejo unos espacios "invisibles" en cada SI y en cada NO.
Y lo que dices tu, en tu formula tienes delspues del SI un espacio y cierras comillas y esto no se refleja al escribirlo.
Haber si esto pueden arreglarlo.
Por mi tema cerrado, me da cosa cerrarlo pues aun no he cerrado ninguno :-)
De todas formas siempre es bueno esperar algun dia más por si aporta alguien cualquier cosa mañana, ya que aqui en España es hora de dormir.
Gracias Armando, he de repasar algo más la función SUMAPRODUCTO, ya que no le he prestado en general mucha atención y es muy importante.

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 09/03/2010

Los espacion son problema del foro, por eso prefiero suban ejemplos.
Para cerrar debe avisar el iniciador del debate.
Trabajas de noche?

Nacho Valdés
Cádiz, España
Escrito por Nacho Valdés
el 09/03/2010

Estimados Amigos, antes que nada mil gracias a todos en general y a vosotros dos en particular. Funciona a la perfección, lo único que me he permitido cambiar de la fórmula que me indicáis =SI(SUMAPRODUCTO(B$2:B$11= B3 )*(E$2:E$11="SI "))>0;"VER";"") es lo siguiente =SI(SUMAPRODUCTO(B$2:B$11= B2 )*(E$2:E$11="SI "))>0;"VER";""), ya que si pongo B3 no funciona bien. Por lo demás perfecto.

Repito mi agradecimiento y me la guardo para mi excelteca particular que tanto me ayuda en mi trabajo.

Un abrazo,
Nacho

Fernando Excel Dudasexcel@hotmail.com
Informatica conde de casal
Escrito por Fernando Excel Dudasexcel@hotmail.com
el 09/03/2010

Pues... Cierro mi primer Post por estar resuelto el problema de Nacho :-)