En este grupo En todos

Foro de Excel



Quitar #VALOR de las celdas

Escrito por Vale
el 31/01/2008
He confeccionado una hoja de cálculo para notificarme cuando ciertos productos caducan. En una celda he introducido una fórmula par avisarme de caducidad antes de un mes y en otra cuando ha caducado totalmente. El problema es que, a pesar de que las formulas funcionan correctamente, en la columna de las celdas donde estan introducidas las formulas me sale la palabra #VALOR. ¿Habría manera de quitar la palabra de las celdas sin que las formulas perdiesen su funcion?.
Jose M Garcia
Madrid, España
Escrito por Jose M Garcia
el 31/01/2008
Hola Vale,

puedes utilizar la función SI para ello.

Imaginemos que queremos dividir F11 entre G11 y cuando de error esta división que se quede la celda sin nada de texto. Pues bien, la fórmula que tendríamos que poner en la celda donde queremos mostrar el resultado de esa división sería la siguiente:

=SI(ESERROR(F11/G11);"";F11/G11)

Un saludo.

Escrito por Vale
el 01/02/2008
" Hola Vale,

puedes utilizar la función SI para ello.

Imaginemos que queremos dividir F11 entre G11 y cuando de error esta división que se quede la celda sin nada de texto. Pues bien, la fórmula que tendríamos que poner en la celda donde queremos mostrar el resultado de esa división sería la siguiente:

=SI(ESERROR(F11/G11);"";F11/G11)

Un saludo.

"

por Jose M (Enero 2008)

Lamento ser un pesado Jose M, pero mi problema es que en la celda que quiero que me de el resultado ya tengo introducida la siguiente fórmula: =SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&" días para caducar. ";""). Como hago para introducir la que tu me propones?. GRACIAS por todo.

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 06/02/2008

Incorpora en esa formula la sugerencia de Vale, algo asi:

= SI(ESERROR( SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&" días para caducar ;""; SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&" días para caducar )

Escrito por Vale
el 06/02/2008
"Incorpora en esa formula la sugerencia de Vale, algo asi:
= SI(ESERROR( SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&" días para caducar ;""; SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&" días para caducar )

"

por Armando Montes (Febrero 2008)


A ver Armando te cuento como he creado la hoja. Vaya de entrada que tu formula no funciona. En la celda A2 pongo el nombre del producto, en la A3 la fecha actual: =SI(A2>0;HOY();""), en la celda A4 la fecha de caducidad del producto. Y en la A5 quiero que me avise cuando falte un mes para caducar el pdroducto e introduzco la formula: =SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&"días para caducar. ";""). El problema que tengo es que al copiar esta formula al resto de la columna me sale escrita la palabra #VALOR. A pesar de que la formula funciona correctamente, no me gusta que en las celdas se vea esa palabra. He probado con formato condicional etc... Y no funciona. Te agradezco de todas formas el tiempo que me has dedicado. GRACIAS.
Escrito por Vale
el 06/02/2008
"Incorpora en esa formula la sugerencia de Vale, algo asi:
= SI(ESERROR( SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&" días para caducar ;""; SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&" días para caducar )

"

por Armando Montes (Febrero 2008)

A ver Armando te cuento como cree la hoja. Vaya por delante que tu formula no funciona. En la celda A1 pongo el nombre del producto, En la A2 la fecha actual:  =SI(A2>0;HOY();""), en la A3 la fecha de caducidad del producto, en la A4 quiero que me avise cuando quede un mes para caducar: =SI($C2-$B2<=31;"Quedan "&SIFECHA($B$2;$C$2;"D")&"días para caducar. ";""), y en la A5 quiero que me avise cuando caduque: =SI(C2<=B2;"Caducado hace "&SIFECHA(C2;B2;"D")&" días";""). El problema, te comentaba, esta en que a pesar de que la formula funciona correctamente y en las celdas me da el valor correcto, me sale siempre la palabra #VALOR. Mi pregunta era si existia la manera de que esa palabra no saliera sin modificar el resultado. Lo he probado con formato condicional tambien y nada. De todos modos gracias por tu tiempo.


Marco Jimenez
Campeche, México
Escrito por Marco Jimenez
el 29/04/2010

Buenas tardes tengo la siguiente formula:

=si(contar. Si('balanza semifinal'! A:a,i29),buscarv(i29,'balanza semifinal'! A:g,7,0),"")/1000

Y el resultado que obtengo es # ¡Valor! , porque lo que esta buscando no existe en el catalogo de cuentas.

Lo que quiero es quitar es error y que me dé como resultado es cero o que quede la celda vacia, para que puedan sumar las demás partidas que tengo.

Por su apoyo mil gracias!

Atte.

Marco


Cacho Rodríguez
Ing. electrónica u.n.r.
Escrito por Cacho Rodríguez
el 29/04/2010

Hola! Marco. Te has incorporado a un debate cerrado desde febrero/2008.

Para recibir una mejor atención, abre tu propio debate a través del enlace:
Crear nuevo debate

Saludos, Cacho.