En este grupo En todos

Foro de JSP

Escrito por Sarahi
el 07/09/2006
Escrito por Edwin
el 26/09/2006

Necesito ke alguien me ayude con este problema ke tengo.

Estoy realizando una aplicacion utilizando tomcat 5. 5, J2sdk, y utilizando Spring Framework, y cuando estoy ejecutando una consulta en mi aplicacion me aparece este error HTTP Error 404, necesito ayuda con esto porfa si alguien puede ayudarme se lo agradecere...

Escrito por Perico
el 11/10/2006

java.net.BindException: Address already in use: Ya tienes algo arrancado en ese direccion. Posibles soluciones:

1. -  Tirar lo que tengas arrancado en ese dir:puerto  e intentarlo de nuevo

2. - Arrancarlo directamente en otro puerto.


(Yo me inclino por la primera, ya que seguramente se te habra quedado colgada en alguna ocasion o te habras olvidado de tirar el servidor.)

Tarde pero espero que te sirva....

Saludos.

Escrito por Jack
el 31/10/2006

El problema que tienes es que tu tomcat quiere utilizar el puerto 8080 pero alguien mas lo esta utilizando.


Hay 2 soluciones:

Checa que otra aplicacion usa el puerto 8080 y parala.

Cambia en la carpeta de configuracion el puerto que utiliza por defecto el tomcat

Escrito por Lina Marcella
el 15/12/2006

Buenas tardes.

Resulta que tengo instalado Tomcat 5. 5 y hay un enlace https://www.grupoconsultoria.com. Co/boletin. Htm  el cual cuando los clientes quieren acceder a Suscribirse al Boletin no me abre la pagina y me dice que no se puede encontrar la pagina. Pero si abro este mismo link en la red de mi trabajo si me lo abre, sera que alguien me puede ayudar, que podra se esto?

Gracias.


Escrito por Sergio
el 05/01/2007

Jejejeje tengo esactamente el mismo problema ke tu si encontraste la solucion avisame por favor Gracias

Saludos!

Escrito por Lina Marcella
el 05/01/2007
Hola Sergio. No aun no he podido solucionar el problema. Si sabes algo tambien te lo agradeceria.
Escrito por Sergio
el 05/01/2007

Tengo el mismisimo problema, si resuelves algo porfavor avisame Gracias!

Saludos

Dennysse Fajardo Avila
Computación e informática instituto su...
Escrito por Dennysse Fajardo Avila
el 18/01/2007

Cuando ejecuto el servlet o jsp empieza a cargar pero casi al final de haber cargado se muestra una ventana pidiendo nombre de usuario y password, pero por mas que ingreso mi nombre de usuario y mi password  se borra la ventana e inmediatamente  se vuelve a mostrar,

He desinstalado el java con el sdk y lo he vuelto a instalar pero sigue con el mismo problema. No se que hacer.

Alguien ayudeme please.


Escrito por Ara
el 21/02/2007

Hola,

Quiero levantar una apliación Web, con hibernate struts y spring,,,pero al arrancar el tomcat genera el siguiente error:

INFO: The Apache Tomcat Native library which allows optimal performancein production environments was not found on the java.library.path:C:\Archivos deprograma\Java\jre1.5.0_06\bin;. ;C:\WINDOWS\system32;C:\WINDOWS;C:\Perl\bin\;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\Archivosde programa\ATI Technologies\ATI Control Panel;C:\Archivos deprograma\MySQL\MySQL Server 4. 1\bin
21-feb-2007 19:44:46 org.apache.coyote. Http11. Http11BaseProtocol init
INFO: Inicializando Coyote HTTP/1. 1 en puerto http-8080
21-feb-2007 19:44:46 org.apache.catalina. Startup. Catalina load
INFO: Initialization processed in 2047 ms
21-feb-2007 19:44:46 org.apache.catalina. Core. StandardService start
INFO: Arrancando servicio Catalina
21-feb-2007 19:44:46 org.apache.catalina. Core. StandardEngine start
INFO: Starting Servlet Engine: Apache Tomcat/5.5.15
21-feb-2007 19:44:46 org.apache.catalina. Core. StandardHost start
INFO: Desactivada la validación XML
log4j:WARN No appenders could be found for logger (org.apache.catalina. Startup. TldConfig).
log4j:WARN Please initialize the log4j system properly.
21-feb-2007 19:44:48 org.apache.catalina. Core. StandardContext start
GRAVE: Error listenerStart
21-feb-2007 19:44:48 org.apache.catalina. Core. StandardContext start
GRAVE: Falló en arranque del Contexto [/EFACTURA] debido a errores previos
log4j:WARN No appenders could be found for logger (org.apache.catalina. Session. ManagerBase).
log4j:WARN Please initialize the log4j system properly.
21-feb-2007 19:44:50 org.apache.catalina. Core. StandardContext start
GRAVE: Error listenerStart
21-feb-2007 19:44:50 org.apache.catalina. Core. StandardContext start
GRAVE: Falló en arranque del Contexto [/factura] debido a errores previos
21-feb-2007 19:44:51 org.apache.coyote. Http11. Http11BaseProtocol start
INFO: Arrancando Coyote HTTP/1. 1 en puerto http-8080
21-feb-2007 19:44:51 org.apache.jk. Common. ChannelSocket init
INFO: JK: ajp13 listening on /0.0.0. 0:8009
21-feb-2007 19:44:51 org.apache.jk. Server. JkMain start
INFO: Jk running ID=0 time=0/266  config=null
21-feb-2007 19:44:52 org.apache.catalina. Storeconfig. StoreLoader load
INFO: Find registry server-registry. Xml at classpath resource
21-feb-2007 19:44:52 org.apache.catalina. Startup. Catalina start
INFO: Server startup in 6297 ms


Alguien sabría de k es?

El fichero web. Xml del  WEB-INF es el siguiente:

<? Xml version="1. 0" encoding="ISO-8859-1"? >
<web-app xmlns="https://java.sun.com/xml/ns/j2ee"
    xmlns:xsi="https://www.w3.org/2001/XMLSchema-instance"
    xsi:schemaLocation="https://java.sun.com/xml/ns/j2ee https://
    java.sun.com/xml/ns/j2ee/web-app_2_4. Xsd" version="2. 4">
   
    <display-name>EFACTURA</display-name>
   
            <! -- Standard Action Servlet Configuration (with debugging) -->
          <servlet>
            <servlet-name>action</servlet-name>
           <servlet-class>org.apache.struts. Action. ActionServlet</servlet-class>
            <init-param>
              <param-name>config</param-name>
             <param-value>/WEB-INF/struts-config. Xml</param-value>
            </init-param>
            <init-param>
              <param-name>debug</param-name>
              <param-value>2</param-value>
            </init-param>
            <init-param>
              <param-name>detail</param-name>
              <param-value>2</param-value>
            </init-param>
            <load-on-startup>2</load-on-startup>
          </servlet>
         
         
          
          
           <! -- Standard Action Servlet Mapping -->
          <servlet-mapping>
            <servlet-name>action</servlet-name>
            <url-pattern>*. Do</url-pattern>
          </servlet-mapping>
         
          <welcome-file-list>
            <welcome-file>index. Jsp</welcome-file>
        </welcome-file-list>
   
          <error-page>
              <error-code>404</error-code>
             <location>/WEB-INF/pages/error/error404. Jsp</location>
          </error-page>
       
   
   
         <! -- Struts Tag Library Descriptors -->
         
         <taglib>
        <taglib-uri>/tags/struts-bean</taglib-uri>
           <taglib-location>/WEB-INF/tld/struts-bean. Tld</taglib-location>
          </taglib>

          <taglib>
            <taglib-uri>/tags/struts-html</taglib-uri>
           <taglib-location>/WEB-INF/tld/struts-html. Tld</taglib-location>
          </taglib>
          <taglib>
            <taglib-uri>/tags/struts-html-el</taglib-uri>
           <taglib-location>/WEB-INF/tld/struts-html-el. Tld</taglib-location>
          </taglib>
         
          <taglib>
            <taglib-uri>/tags/struts-logic</taglib-uri>
           <taglib-location>/WEB-INF/tld/struts-logic. Tld</taglib-location>
          </taglib>
       
          <taglib>
            <taglib-uri>/tags/struts-nested</taglib-uri>
           <taglib-location>/WEB-INF/tld/struts-nested. Tld</taglib-location>
          </taglib>
       
          <taglib>
            <taglib-uri>/tags/struts-tiles</taglib-uri>
           <taglib-location>/WEB-INF/tld/struts-tiles. Tld</taglib-location>
          </taglib>
         
           <taglib>
            <taglib-uri>/tags/display-tags</taglib-uri>
           <taglib-location>/WEB-INF/tld/displaytag. Tld</taglib-location>
          </taglib>
         
           <taglib>
            <taglib-uri>/tags/format</taglib-uri>
            <taglib-location>/WEB-INF/tld/fmt. Tld</taglib-location>
          </taglib>
         
          <taglib>
            <taglib-uri>/tags/core</taglib-uri>
            <taglib-location>/WEB-INF/tld/c. Tld</taglib-location>
          </taglib>
       
          <taglib>
            <taglib-uri>/tags/core-rt</taglib-uri>
            <taglib-location>/WEB-INF/tld/c-rt. Tld</taglib-location>
          </taglib>
       
          <taglib>
            <taglib-uri>/tags/struts-logic</taglib-uri>
           <taglib-location>/WEB-INF/tld/struts-logic. Tld</taglib-location>
          </taglib>     
         
          <taglib>
            <taglib-uri>/tags/fn</taglib-uri>
            <taglib-location>/WEB-INF/tld/fn. Tld</taglib-location>
          </taglib>
               
         
               <! -- Spring
          <servlet>
              <servlet-name>SpringContextServlet</servlet-name>
              <servlet-class>org.springframework.web. Context. ContextLoaderServlet</servlet-class>    
              <load-on-startup>1</load-on-startup>
        </servlet>-->
       
        <listener>
           <listener-class>org.springframework.web. Context. ContextLoaderListener</listener-class>
        </listener>
   
   
        <context-param>
            <param-name>contextConfigLocation</param-name>
            <param-value>
              classpath:java/applicationContext. Xml,classpath:java/applicationContextDao. Xml,classpath:java/applicationContextManager. Xml
            </param-value>
        </context-param>
       
       
         <filter>
            <filter-name>hibernateFilter</filter-name>
            <filter-class>
             org.springframework.orm. hibernate3.support.OpenSessionInViewFilter
            </filter-class>
           </filter>   
          <filter-mapping>
            <filter-name>hibernateFilter</filter-name>
             <url-pattern>*. Do</url-pattern>
          </filter-mapping>
       
</web-app>


Un saludo GraciaS


Escrito por Monica
el 21/02/2007
Escrito por Javi
el 01/03/2007

Lina_marcella, sabes si los puertos del firewall de tu empresa están abiertos para el servidor donde tienes alojada la web?

Un saludo, suerte.

Escrito por Cris
el 03/03/2007
A mi me pasa igual estoy asta los co... Por la#! @##@da esa es que cada 10 minutos o 5 se me pone esta pag web...
Escrito por Gabriel Bandala
el 21/03/2007

Deseo saber si alguien ha trabajado con el tomcat y bravaviewer, lo he instalado sin problemas y corrido los ejemplos tambien, pero via local, quiero saber como le hago para publicar en rutas fisicas en otro servidor y alterar el repositorio donde toma los archivos dwf para tomarlos sin estar en el propio servidor al igual que los dierctorios de los markups.

Gracias de antemano cualquier informacion


Escrito por Gema
el 11/05/2007

Hola,

Me ha pasado una cosa realmente extraña con el tomcat 5. 5, a ver si a alguien ya le ha pasado  y me puede ayudar.

De repente sin tocar nada se le va la pinza y no carga la página de mi aplicación, pero lo paras y lo vuelves a arrancar y ya sí que carga.

Muchas gracias si alguien puede ayudarme.

Gema

Escrito por Aeris
el 25/05/2007

Hola he usado el modulo mod_jk de apache para conectarlo con tomcat. He seguido las indicaciones de esta pagina>> https://mundogeek. Net/archivos/2006/04/04/apache-y-tomcat-en-windows/

Pero aunque los dos arrancan perfectamente al poner https://localhost:8080 me sale la pagina de apache y en https://localhost no me encuentra nada. Si paro el apache me sale la pagina de tomcat en https://localhost:8080. No entiendo demasiado del tema y no se que he podido hacer mal. He seguido los pasos y los he revisado.

¿Que puede fallar?

¿Alguna idea para solucionarlo?

Gracias

Escrito por Aeris
el 25/05/2007

Hola he usado el modulo mod_jk de apache para conectarlo con tomcat. He seguido las indicaciones de esta pagina>> https://mundogeek. Net/archivos/2006/04/04/apache-y-tomcat-en-windows/

Pero aunque los dos arrancan perfectamente al poner https://localhost:8080 me sale la pagina de apache y en https://localhost no me encuentra nada. Si paro el apache me sale la pagina de tomcat en https://localhost:8080. No entiendo demasiado del tema y no se que he podido hacer mal. He seguido los pasos y los he revisado.

¿Que puede fallar?

¿Alguna idea para solucionarlo?

Gracias

Escrito por Javier
el 21/06/2007

Hola,
Estoy haciendo un proyecto con jsp como presentación ,java(j2sdk1.4.2), mysql5 y Tomcat (Apache Tomcat 5.0.28 Server).
Mi problema está en el momento de llamar desde un jsp a un servlet.
He probado a declarar una clase java desde el jsp de mil maneras diferentes y muchas de ellas deberían haber funcionado, ya que eran copiadas literalmente de proyectos que funcionan bien.
Esto me lleva a pensar que tengo un problema con tomcat. Cuando intento ejecutar una aplicacion jsp que tenga declarada una clase java me da el siguiente error:

org.apache.jasper. JasperException: No se puede compilar la clase para JSP

Ha tenido lugar un error en la línea: 30 en el archivo jsp: /prueba1. Jsp
Error de servlet generado:
C:TomcatworkCatalinalocalhostpfcorgapachejspprueba1_jsp. Java:73: cannot


Quioen me puede ayudar con este  problema, 

Escrito por Sadf
el 02/08/2007

Pues yo tengo el mismo problema, installo el tomcat pero cuando abro la pagina de index del tomcat y quiero ir al link the status o algun link me aparece como si no existiera la pagina, eso significa que no esta levantanto el tomcat y por eso no levanta la pagina?

Como le hago install y desinstalo pero no se soluciona, como le hago.. Gracias.