En este grupo En todos

Grupo de Microsoft Excel



Para que sirve la doble comilla ( " ") en las funciones

Arturo
Argentina
Escrito por Arturo Ponzinibbio
el 26/02/2008

Hola... Les quería consultar en que casos se utiliza la doble comilla en las funciones, por ejemplo en la función SI, he visto casos en que en algunos de los criterios, se utiliza las doble comillas.
Gracias y saludos...

Julio Cesar Mendoza Arango
Licenciado en contaduria universidad n...
Escrito por Julio Cesar Mendoza Arango
el 26/02/2008

La doble comilla se utiliza para valores de texto
en la funcion Si es cuanto comparas contra un texto, o la respuesta quieres que salga un texto
ejemplo
=Si(A2<5. 9,"reprobado","aprobado")
si el numero de A2 es menor que 5. 9 el resulatado sera reprobado
si el numero de A2 es mayor que 5. 9 el resultado sera aprobado

Césarxp Ruben Pastor
(75) Paris, Francia
Escrito por Césarxp Ruben Pastor
el 26/02/2008

La DOBLE COMILLA también se utiliza, para dejar una celda en blanco o para hacer referencia a una celda en blanco

DEJAR UNA CELDA EN BLANCO

=SI(Y(A3<5,B3>7),A3*B3," ")

Explicación :

Para que los valores contenidos en la celda A3 y B3 se multipliquen, obligatoriamente debe de cumplirse las condiciones especificadas, es decir, que todo lo que este contenido en la celda A3 TIENE

Césarxp Ruben Pastor
(75) Paris, Francia
Escrito por Césarxp Ruben Pastor
el 26/02/2008

La DOBLE COMILLA también se utiliza, para dejar una celda en blanco o para hacer referencia a una celda en blanco

DEJAR UNA CELDA EN BLANCO

=SI(Y(A3<5,B3>7),A3*B3," ")

Explicación :

Para que los valores contenidos en la celda A3 y B3 se multipliquen, obligatoriamente debe de cumplirse las condiciones especificadas, es decir, que todo lo que este contenido en la celda A3 tiene que ser menor que 5, luego todo lo que este contenido en la celda B3 tiene que ser mayor que 7, entonces si eso es asi, se procede a efectuar la multiplicación de ambos valores, y si eso no es asi, es decir si la condición no se cumple, entonces, LAS COMILLAS indican que se debe dejar la CELDA VACIA


HACER REFERENCIA A UNA CELDA EN BLANCO

=SI(O(A7="",B7=""),"Faltan datos",A7*B7)

Explicación :

Esto quiere decir lo siguiente, si cualquiera de ellas, es decir cualquiera de las celdas A7 o B7 estuvieran vacias, entonces escribir la expresión FALTAN DATOS pero si ambas contenieran datos, entonces se procederia a la MULTIPLICACION que se indica.

Alvaro Narvaez
Contador publico universidad javeriana
Escrito por Alvaro Narvaez
el 26/02/2008

La doble comilla, es una exprecion que sirve para delimitar el valor de una variable, una constante, o una accion, como en los ejemplos anteriores "faltan datos", solo se la utiliza para expresiones de tipo cadena, nunca con expresiones de tipo numerico, en este caso la respuesta por la condicion si toma el valor de faltan datos , pero si tu colocas la doble comilla sin espacion asi "" le asignas un valor de vacio, que esdiferente a la " ", la primera respuesta es vacio y la segunda respuesta es un espacio, que cuando se trata de validar el valor que tienes en una celda los dos son totalmente diferente, que si quieres lo puedes comprobar asi por ejemplo en la celda A1 tienes 10 y en la celda B1 haces la siguiente formula =si(a1<>10,"correcto","") y en la celda B2 la siguiente formual =si(a1<>10,"correcto"," ") ahora para comprobar lo anterior usamos la funcion codigo para determinar las diferencias, en la celda C1 la formula =codigo(b1) y en la celda C2 la formula =codigo(b2) y comparamos las respuestas en la celda C1 genera un error #valor, por que el contenido es un nullo sin valor y en la Celda C2 la respuesta es 32 que equivale a un espacio, ahi notamos la diferencia que a simple vista no nos damos cuenta de eso.

Escrito por Arturo Ponzinibbio
el 04/03/2008

Gracias a todos por responder, me han ayudado mucho.
Saludos.

Valery Assia
Sucre, Colombia
Escrito por Valery Assia
el 08/12/2011

=SI(SUMA(C12:R12)=0;"";SUMAPRODUCTO(C12:R12;$C$8:$R$8)/(SUMAR. SI(C12:R12;"<>";$C$8:$R$8)-SUMAR. SI(C12:R12;"=E";$C$8:$R$8)))

Tengo esta formula y no se que significa o cmo solucionarla, no he podido entenderla es de un registro de notas de clases me explica?

Muchas gracias, me sirvio mucho