En este grupo En todos

Foro de Datamining



macros excel

Escrito por Dudas
el 01/08/2006

Hola!

Tengo una hoja excel dinamica, es decir, va cambiado de dimensiones, y necesito sumar los valores de una columna. La cosa es q a veces en esa colunma hay tres celdas y otras veces hay mas o menos.... Por lo tanto no puedo seleccionar esas celdas y hacer "suma(c1,c2,c3....)

Alguien puede echarme una mano?



Escrito por St7
el 12/12/2006

Prueba con esta macro:

Sub Sumar()
[c65536]. End(xlUp). Offset(1, 0). Select
ActiveCell. FormulaLocal = "=SUMA(C1:C" & [c65536]. End(xlUp). Row & ")"
End Sub

Salu2 de ST   suerte

P:D:_si me permites. -personalmente yo lo hubirera hecho asi:

En D1 ponria la suma de la columna "C" asi :

=suma(C:C) ;asi en la medida que meto los datos automaticamente me daria el resultado en la celda D1,pero bueno preferiste una macro ,pero siempre recomiendo "economia" en cualquier proceso

Por cierto la desventaja de la macro es que siempre tendras que pulsart un boton o autoforma mediante el cual llames a la macro,no asi con la solucion anterior  [lo hara automaticamente].

Escrito por Oscar
el 12/12/2006

Veo que hace rato hiciste la consulta, la resolviste? , si la necesitas enviame un correo a oscarlm23@hotmail. Com .

Espero pueda ayudarte

Escrito por Nieves
el 16/01/2007

Tengo una pregunta  acerca de las aplicaciones  de las macros en economia, administracion  y matematicas, y si me pueden dar ejemplos

Oskar
Sinaloa, México
Escrito por Oskar
el 17/02/2007

Tengo una macro en office 97 que me pasa las celdas escritas con numero a formato de letra. Un ejemplo: teno una celda = $1,250. 00

Y me la convierte a = Son (Un Mil doscientos cincuenta pesos )

La quiero pasar a Office 2007 pero me marca erros como le hago, me tendria que meter al editor d Visual Basic? Que opinan

Escrito por Juancho
el 13/06/2007

Desde la hoja 1 hago un boton de formulario

Para que ejecute un macro de imprimir la hoja 2

La cual esta hoja 2 esta oculta

Como hago ese macro?

Gracias

Escrito por Jorge
el 17/08/2007
hola, lo que quiero es me ayuden o enseñen a crear una macros para una liquidadcion de sueldos, porfa es urgente
Hackstar
San Luís Potosí, Méx...
Escrito por Hackstar
el 15/12/2008

Bien que tal so daniel de san luis potosí quisiera saber si me pudieran echar la mano, tengo una hoja de excel con un inventario de articulos, revueltos obvio, entonces quisiera saber si hay una macro que cuando yo consulte el ariculo ésta me diga cual es el valor total por articulo o sea qe me sume los valores de todos los articulos con el mismo nombre que yo consulte, espero poder recibir su ayuda, gracias...

Nada Nada
Estado de México, Mé...
Escrito por Nada Nada
el 08/10/2010

Gracias por tu apoyo