En este grupo En todos

Foro de Excel



Funciones de excel con SI(Y

sito
León, España
Escrito por Sito Pons
el 10/04/2008
Codigo Fecha Matricula1 Hora1 Neto Fecha Hora2 Matricula2
Codigo Neto
2551301 09/04/08 1514DPH 7:26 25420 09/04/08 9:22 1514DPH 25430
2051301 09/04/08 1514DPH 9:52 25500 09/04/08 10:34 1514DPH 25550
2051301 09/04/08 1514DPH 11:05 23600 09/04/08 11:44 1514DPH 23650
2051301 09/04/08 1514DPH 12:17 25400 09/04/08 13:01 1514DPH 25460
2551301 09/04/08 1514DPH 13:30 25350 09/04/08 14:13 1514DPH 25370
2551301 09/04/08 1514DPH 16:21 25660 09/04/08 17:30 1514DPH

25680



Ficheros adjuntos:
Formulas excel
Abraham Valencia
Computacion e informatica microsoft mv...
Escrito por Abraham Valencia
el 10/04/2008
Ahhh... Y ya leista al menos "algo" de como usar "Y", "O" y "SI"?

Abraham
Sito Pons
León, España
Escrito por Sito Pons
el 10/04/2008
" Ahhh... Y ya leista al menos "algo" de como usar "Y", "O" y "SI"?

Abraham "

por Abraham Valencia (Abril 2008)


Lo siento, con dos condiciones ya lo tengo, pero con tres no soy capaz o a lo mejor no se puede
Abraham Valencia
Computacion e informatica microsoft mv...
Escrito por Abraham Valencia
el 10/04/2008
Pues, realmente no entiendo en que te hiciste problemas:

=SI(Y(I2=C2,H2>D2,H2<D3),A2,"")

OJO, estoy tomando como que la columna A es la rpimra, y que cuando dices "hora1siguiente", te refieres a la de la fila inmediata inferior

Abraham
Sito Pons
León, España
Escrito por Sito Pons
el 10/04/2008
" Pues, realmente no entiendo en que te hiciste problemas:

=SI(Y(I2=C2,H2>D2,H2<D3),A2,"")

OJO, estoy tomando como que la columna A es la rpimra, y que cuando dices "hora1siguiente", te refieres a la de la fila inmediata inferior

Abraham "

por Abraham Valencia (Abril 2008)


Si, me refiero a la fila inmediata inferior, pero a mi me da error


Abraham Valencia
Computacion e informatica microsoft mv...
Escrito por Abraham Valencia
el 10/04/2008
Pero, que error? OJO, ajustaste a tus rangos reales? Yo uso "coma" como separador de listas, no sera que tu usas "punto y coma"?

Abraham
Sito Pons
León, España
Escrito por Sito Pons
el 10/04/2008
" Pues, realmente no entiendo en que te hiciste problemas:

=SI(Y(I2=C2,H2>D2,H2<D3),A2,"")

OJO, estoy tomando como que la columna A es la rpimra, y que cuando dices "hora1siguiente", te refieres a la de la fila inmediata inferior

Abraham "

por Abraham Valencia (Abril 2008)

Perdona Abraham, te he puesto este caso y simplemente con dos condiciones serviría, pero lo que yo quiero es que se cumplan las tres, es decir que sea igual que otra, mayor que otra y menor que otra y perdona porque me hago un lio y a lo mejor tiene otra solucion más sencilla

Sito Pons
León, España
Escrito por Sito Pons
el 10/04/2008
" pero, que error? OJO, ajustaste a tus rangos reales? Yo uso "coma" como separador de listas, no sera que tu usas "punto y coma"?

Abraham "

por Abraham Valencia (Abril 2008)

Yo uso "punto y coma", pero con la "coma", tampoco me funciona

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 11/04/2008

Si quieres enviame el archivo directamente, con las explicaciones pertinentes y un ejemplo del resultado a obtener, y te lo arreglo.

AMontes@mail. Com


Sito Pons
León, España
Escrito por Sito Pons
el 11/04/2008
" Si quieres enviame el archivo directamente, con las explicaciones pertinentes y un ejemplo del resultado a obtener, y te lo arreglo.
AMontes@mail. Com
 
"

por Armando Montes (Abril 2008)


Para este caso me ha servido con el SI(Y cuando se cumplen dos condiciones, pero si tuviesen que cumplirse tres condiciones no se como hacerlo. Es decir desarrollar el SI(Y teniendo que cumplirse tres condiciones para dar un resultado.

Gracias de antemano.

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 11/04/2008

Abraham te dio la formula para 3 condiciones