En este grupo En todos

Foro de Excel



funcion PROMEDIO.SI en celdas aisladas

carlos
Perú, Perú
Escrito por Carlos Acevedo
el 03/01/2011

Amigos como estan, subí un doc donde tengo datos en 4 celdas, en la 1ra ya tiene datos (mes enero), las sgtes (de feb a abril) todavia estan vacias
queria usar PROMEDIO como ven, pero me promedia tambien las celdas con valor cero, entonces encontré la PROMEDIO. SI, e hice la sgte pruebita

=+PROMEDIO. SI(A17:G17),">0",(A17:G17)) y funcionó,


pero al aplicarla a datos q no están contiguos, sale error:


=+PROMEDIO. SI(A10,C10,E10,G10),">0",(A10,C10,E10,G10))

como debe ser el tratamiento en este caso? Porque para la PROMEDIO, sí me acepta esas referencias de celda:
=+PROMEDIO(A4,C4,E4,G4)

Cacho Rodríguez
Ing. electrónica u.n.r.
Escrito por Cacho Rodríguez
el 03/01/2011

Hola! Carlos
La función "PROMEDIO. SI" NUNCA te va a funcionar por la sencilla razón que los números a promediar no se encuentran en celdas contiguas (el rango en cuestión no debe tener "huecos").

Por ejemplo entre las celdas A10 y C10, no estás considerando la celda B10...

¿Solución?... Sencillo: cambia la disposición de los datos a promediar.
Saludos, Cacho.

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 03/01/2011

Intenta con algo asi:
=SUMA(A10:G10)/CONTAR(A10:G10)

Carlos Acevedo
Perú, Perú
Escrito por Carlos Acevedo
el 04/01/2011

Gracias amigos, como no me acepta PROMEDIO. SI ni CONTAR. SI para esa ordenacion de datos en particular, tuve q optar x una solucion práctica, lo pueden ver en el archivo q subí

queria hacerlo todo en una sola instruccion, pero si no se puede...

Carlos Acevedo
Perú, Perú
Escrito por Carlos Acevedo
el 05/01/2011

Armando, descargué el archivo q pones, pero no veo ninguna solucion, sigue con la fila auxiliar q le puse, verifica el link, o el foro m redirecciona mal?

Alejandro Federico
Licenciado en contaduria universidad a...
Escrito por Alejandro Federico
el 05/01/2011

Carlos, pues tu misma solucion puesta en una celda, por ejemplo esta formula en J3

=I3/(SI(A3>0,1,0)+SI(C3>0,1,0)+SI(E3>0,1,0)+SI(G3>0,1,0))

Tal vez debas cambiar las comas ( , ) por punto y coma ( ; )

Saludos.

Carlos Acevedo
Perú, Perú
Escrito por Carlos Acevedo
el 06/01/2011

Gracias amigos x participar
la solucion d alejandro me parece la mas practica,(no puedo decir "y obvia" x q no la vi! ), solo q para sacar promedios cuando se tenga algun negativo (para mi caso de promedio de gastos está ok la rspta de alejandro), habria q modificar a:
=I3/(SI(A3<>0,1,0)+SI(C3<>0,1,0)+SI(E3<>0,1,0)+SI(G3<>0,1,0))

armando: encontre tu archivo (x finnn), no era el q linkeaste, tu formulita m parece interesante, voy a estudiarla ( no conocia la funcion RESIDUO ni COLUMNA, no se si estaran en el excel 2003 q es el q manejo en la oficina), y voy a tratar de sacar promedio tambien cuando se incluya algun num negativo, ejm:
para 10, 8, 3 -1, el prom debe ser 5, voy a tratar de encontrar esta rspta con tu formula, como q la estudio