En este grupo En todos

Foro de Excel



Facturar usando Base de Datos en EXCEL

Escrito por Andres
el 22/06/2006
Alguien podria ayudarme? Tengo una base de datos en EXCEL con clientes con su datos Nombre, Direccion,RFC,etc. Y una planilla tambien en excel con un formato propio para facturar. Como puedo pasar los datos (Nombre, Dirreccion, RFC) a las celdas de mi planilla Factura en forma automatica? Es decir, oprimir una tecla, ver mi base de datos, seleccionar el cliente y que sus datos aparezcan en mi planilla Factura. Si alguin me lo puede decir se los agradeceria mucho.
Francisco Murcia
Valencia, España
Escrito por Francisco Murcia
el 22/06/2006

Buenas tardes,

Hay una opción en la herramientas de Word, que he usado muy satisfactoriamente para hacer circulares de correspondencia y facturas que responde a lo que buscas.

Es muy fácil, Desde Word tienes que acceder a "Combinar Correspondencia" del menú Herramientas,  el formato de factura con el fichero excel, te hablará de un fichero principal que es tu factura y un documento secundario que son los datos, llamas al fichero excel. Es muy intuitivo y haciendo pruebas lo sacaras.

Saludos y SSS.

Escrito por Jose Antonio Bartus Acosta
el 28/06/2006

El Ejemplo anterior es bueno pero creo que no te soluciona el problema. Esta es la solución que yo te propongo.

La base de datos debe tener un campo clave, un campo que no se repita y por donde debe estar ordenada.

Coloca esta formula en cada entrada del formulario donde quieres que aparezca automanticante los datos.

Esta formula  hace los siguiente:

Busca en este caso lo que has puesto en la celda A2 en la hoja BaseDatos en la columana A y si lo encuentra pone lo que aparece en la columna B

Así, si esto lo has puesto en la Celda B2 aparecerá por ejemplo el nombre del cliente si estos estan en la Columna B de la hoja BaseDatos

=SI($A2>0; SI(ESERROR(COINCIDIR($A2;BaseDatos! $A:$A;0));"Codigo No encontrado... ";BUSCAR($A2;BaseDatos! $A:$A;BaseDatos! B:B));"")

Espero que te sirva..


Escrito por Acabgior
el 28/06/2006

Gracias Jose Antonio.

Andaba desde hace tiempo buscando precisamente una fórmula parecida que me facilitase el trabajo. He estado intentando obtenerla de motu propio durante bastante tiempo pero me ha sido imposible.

Gracias. Y por cierto, si existe alguna página especializada o algún libro donde poder aprender este tipo de funciones te agradecería me lo indicases.

Un saludo

Escrito por Andres
el 24/09/2006

Gracias Jose Antonio.

No habia tenido tiempo de implementar tu recomendacion. Ahora lo estoy probando pero mi EXCEL esta en ingles.   Podrias decirme como seria tu solucion en Ingles? Por ejemplo el "SI" seria "IF", el BUSCAR seria FIND, etc. Etc.   Podrias mandarme la ecuacion con formulas en ingles?   Muchisimas gracias.

=SI($A2>0; SI(ESERROR(COINCIDIR($A2;BaseDatos! $A:$A;0));"Codigo No encontrado... ";BUSCAR($A2;BaseDatos! $A:$A;BaseDatos! B:B));"")

Escrito por Isidoro Lama
el 13/01/2007

Hola soy nuevo en este foro, y estoy intentando informatizar la empresa de mi padre, pero como el esta a facor de la informática, quiero empezar con una base de datos facil de clientes, y poder hacer los albaranes y facturas.

Creo que de lo que he estado viendo con excel es la forma más sencilla y fácil para que mi padre también pueda manejarlo, pero no se como puedo empezar.

Alguién me puede ayudar

Carina Valdez
Guadalajara, Argentina
Escrito por Carina Valdez
el 14/03/2007
Hola estaba leyendo sus dudas y me surgio en esta semana una duda que tal vez me enrosco demsiado.... Les cuento lo que quiero hacer es el lbro de iva. La facturacion la tengo algo controlada solo que imrpimo la factura y me gustaria que pasaran los datos del cleinte y demas al libro de iva pero como los datos van cambiando en forma constante cada vez que hago una factura no le encuentro solucion.... Espero que alguno de ustedes pueda ayudarme (carina_valdez@hotmail. Com)
Jon
Guadalajara, España
Escrito por Jon
el 10/10/2007
Hola, estoy intentando hacer las facturas en excel pero con una base de datos para no tener que escribir los clientes siempre, simplemente que cuando me coloque en la casilla se me abra un menu de donde coger los datos del cliente al que voy a hacer la factura. No se si me entendeis, espero que si. Necesito ayuda. Gracias
Sara Sotomayor
Perú, Perú
Escrito por Sara Sotomayor
el 20/02/2008
Encontraste loq buscabas ,?  ami me gustaria tener el programa q tu tienes si me lo permites claro
Escrito por Rafael
el 06/08/2008
" encontraste loq buscabas ,?  ami me gustaria tener el programa q tu tienes si me lo permites claro "
por sara sotomayor (febrero 2008)



tengo un programa para facturar en excel te lo puedo facilitar


Juan Carlos López
Nariño, Colombia
Escrito por Juan Carlos López
el 20/02/2010

Buenos días me podrias facilitar tu programa para facturar en excel.

Muchas gracias

Att, Juan López
jucalo1581@yahoo. Com

Cacho Rodríguez
Ingeniería electrónica universidad nac...
Escrito por Cacho Rodríguez
el 20/02/2010

Hola! Juan Carlos.
Te has incorporado a un debate abierto hace -casi- cuatro años y que no ha tenido movimiento hace un año y medio.

De modo que bien vale la pregunta: ¿A quién le pides facilitarte un libro excel?
Saludos, Cacho.

Cacho Rodríguez
Ingeniería electrónica universidad nac...
Escrito por Cacho Rodríguez
el 04/03/2010

Como era de esperarse: ninguno de los "antiguos" participantes te ha constestado...
Inicia un nuevo debate, entonces.