En este grupo En todos

Foro de Cisco



configurar mode trunk en switch 3560

sergio
Ingenieria de sistemas los libertadores
Escrito por Sergio Benavides
el 18/12/2009

Buenas tardes

Necesito configurar en mode trunk un puerto de mi switch 3560 pero sale el siguiente error
SWSERVERS1(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
, me pueden ayudar?

Mera Otal
Cuenca, España
Escrito por Mera Otal
el 29/12/2009

Entra en la interface en cuestion y ponla en modo full duplex, tal que asi:

SWSERVERS1(config-if)# duplex full

Tambien asegurate de que la interface no este en modo Acces, haz un show interface (y el puerto que quieres), esto te mostrara si el puerto esta en acces. Si lo esta, tienes que quitarlo primero para cambiarlo a modo trunk. Se quita asi:

SWSERVERS1(config-if)# no switchport mode acces

Dependiendo del modelo y el sistema operativo del switch, puede cambiar el orden de los comandos, ayudate utilizando el interrogante si es el caso, aunque creo que tu modelo no te traera problemas.

Roberto
Escrito por Roberto
el 30/12/2009

Hola, para poner un puerto en modo troncal "trunk", switch-port mode trunk, y tienes que seleccionar un tipo de encapsulación, bien la estandard 8021q o la propietaria de cisco isl.
Creo que los comandos son algo así, switch-port encapsulation 8021. Q, y después switch-port mode trunk. Suerte

Un saludo,
Roberto

Benjamin Hermosilla
Santiago, Chile
Escrito por Benjamin Hermosilla
el 12/03/2010

Estimado:
antes de entregar una solucion, me gustaria mencinar algo de teoria:

El protocolo IEEE 802. 1Q fue un proyecto del grupo de trabajo 802 de la IEEE para desarrollar un mecanismo que permita a múltiples redes compartir de forma transparente el mismo medio físico, sin problemas de interferencia entre ellas (Trunking). Es también el nombre actual del estándar establecido en este proyecto y se usa para definir el protocolo de encapsulamiento usado para implementar este mecanismo en redes Ethernet.

Cisco tambien trabajo en el mismo proyecto, sin embargo ellos sacaron su protocolo propietario llamado ISL, el cual a vista de mucho es mucho mejor que 802. 1q, pero no puede ser aplicado para otras tecnologia por lo cual es mu poco usado.

bueno volviendo a tu problema, el switch no te permite utilizar las interfaces en modo trunk por que antes debes definir con cual protocolo realizar el trunk, para indicar esto debes utilizar el siguiente comando:

(config-if)#switchport trunk encapsulation dot1q ( si es el caso) o ISL


por mi parte te recomiendo segir usando dot1q.


espero que esta informacion sea de ayuda.

Rodrigo Herbas Durán
Ing. sistemas electronicos escuela mil...
Escrito por Rodrigo Herbas Durán
el 18/02/2011

Tengo el mismo problema y tratè de solucionarlo utilizando el comando "switch port trunk encapsultation dot1q.... Pero cuando intento me aparece este error:

Gigabit x/x not a switching port" saben que puede ser? Y en este caso estamos hablando de un switch 6500....


Muchas gracias y saludos

Jose Carlos Canepa Bernal
Informatica universidad federico villa...
Escrito por Jose Carlos Canepa Bernal
el 18/02/2011

A ver amigos cuando se ingresa este comando en la interfaz para configurarlo en el modo troncal



SW1(config-if)#switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.



y aparece este mensaje es debido a que la interfaz que quieres configurar.. Esta en modo automatico para la encapsulacion, debes dejarla en modo dot1q
prueba antes de ingresar el switchport mode trunk colocar este comandito..




SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk



y luego revisa la interfaz con:



SW1(config-if)#do sh int fa0/7 switchport



Name: Fa0/7
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled



CLARO ESTO ES PARA UN SWITCH 3560






Y SOLUCIONADO SALUDOS ¡¡¡¡

Jose Carlos Canepa Bernal
Informatica universidad federico villa...
Escrito por Jose Carlos Canepa Bernal
el 18/02/2011

ANTES que nada has verificado que esa interfaz exista o este habilitada?


Para el caso de mi amigo que veo que usa un switch 6500 que como sabra es un switch MULTILAYER O L3 O MULTICAPA bueno lo que debes de hacer es esto


OJO LA CONFIGURACION ES EN UN SWITCH 6500 :



Router> ena
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# int Gi
Router(config)# int GigabitEthernet 0/1?
% Unrecognized command
Router(config)# int GigabitEther
Router(config)# int GigabitEthernet?
<1-6> GigabitEthernet interface number

Router(config)# int GigabitEthernet 1/1
Router(config-if)# sw
Router(config-if)# switchport mo
Router(config-if)# switchport mode tr
Router(config-if)# switchport mode trunk
Command rejected: Gi1/1 not a switching port.
Router(config-if)# sw
Router(config-if)# switchport
Router(config-if)# sw
Router(config-if)# switchport mod
Router(config-if)# switchport mode tr
Router(config-if)# switchport mode trunk
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.
Router(config-if)# sw
Router(config-if)# switchport en
Router(config-if)# switchport enc
Router(config-if)# switchport enca
Router(config-if)# switchport tr
Router(config-if)# switchport trunk en
Router(config-if)# switchport trunk encapsulation do
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# switchport mode trunk
Router(config-if)# no shutdown
Router(config-if)# exit



tienes que tener mucho cuidado al configurar un puerto en mi caso use el comando ranger que tomo varios puertos


sw1(config-if-range)#swit mode dyn auto
Command rejected: Fa0/14 not a switching port.
% Interface range command failed for FastEthernet0/14

sw1(config-if-range)#do sh run int fa0/14
interface FastEthernet0/14
no switchport
ip address 191.1.27. 7 255.255.255.0
end



Vas a estar bien como los puertos enrutados se ignoran los comandos switchport (que se configuran como "no switchport") tienes que deshabilitar la opcion de switchport con el comandos no switchport para que trabaje como un puerto enrutado.




SOLUCIONADO SALUDOS ¡¡¡¡


Benjamin Hermosilla
Santiago, Chile
Escrito por Benjamin Hermosilla
el 18/02/2011

En el modulo de switching utilizas catos o ios?

Jose Carlos Canepa Bernal
Informatica universidad federico villa...
Escrito por Jose Carlos Canepa Bernal
el 18/02/2011

Bueno la respuesta es obvia cuando se trabaja con IOS y CATOS la configuracion es distinta, YA QUE EL COMANDO SWITCHPORT TRUNK ENCAPSULATION DOT1Q solo se ingresa en IOS y no en CATOS



por ejemplo : (equipos reales)



IOS :


SW1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
SW1(config)# int fa0/2
SW1(config-if)# switchport
SW1(config-if)# switchport trunk encapsulation dot1q
SW1(config-if)# switchport mode trunk
3d22h: %DTP-SP-5-TRUNKPORTON: Port Fa4/1 has become dot1q
SW1(config-if)# switchport trunk native vlan 99
SW1(config-if)# ^Z
SW1#




CATOS :



CatOS (enable) set trunk 0/2 on dot1q
Port(s) 4/1 trunk mode set to on.
Port(s) 4/1 trunk type set to dot1q
CatOS (enable) set vlan 99 0/2
VLAN 2 modified.
VLAN 1 modified.
VLAN Mod/Ports
---- -----------------------
2 1/1
0/2




en CATOS se usa el comando set vlan 99 0/2 para poner a la vlan 99 como la vlan nativa en el puerto troncal fa0/2 y si quiero ingresar a una interfaz y configurarlo en modo troncal mas la encapsulacion dot1q se ingresa eset comando SER TRUNK 0/2 ON DOT1Q



como veran es muy diferente y notorio.................. NUESTRO AMIGO USA " IOS "



SALUDOS ¡¡¡¡

Escrito por Rebeca Ramirez Severiano
el 27/09/2011

Exelente! , muy útil.