En este grupo En todos

Foro de Excel



CONDICIONAR A SUMAR SOLO VALORES NUMERICOS

CESAR
Bogotá, Colombia
Escrito por Cesar Dario Vargas
el 27/09/2008

Amigos.. Tengo un gran problema con la suma de un rango de celdas.

Necesito sumar un rango de celdas (j8:af8).

El problema es que en dicho rancho hay valores numericos y hay tambien fechas...

Como haria para que solo me sume los valores numericos de dicho rango?

Gracias

Escrito por Kurama
el 27/09/2008

Hola,

Escribe en la columna de al lado (columna B) la siguiente fórmula y arrástrala: CELDA("formato";A1). Luego, en otra columna escribe la siguiente fórmula: SUMAR. SI(B1:B5000;"G";A1:A5000).

SALUDOS.

Escrito por Ama
el 27/09/2008
Hola
Esta formula matricial puede servirte

SUMA(SI(ESERROR(j8:f8);0;D7:D12))

Formula matricial  Ctr+May+Enter
Escrito por Ama
el 27/09/2008
Me respondo:

Suma tambien  las fechas

Lo que omite  es el texto y tipos de error

lo siento
Arturo Gómez
Mestrado em matemáticas universidade f...
Escrito por Arturo Gómez
el 27/09/2008
Acontece que las fechas en excel son números. Lo que yo me pregunto, es por qué las fechas están mezcladas con las otras cosas, siendo que existen columnas para separarlas. Lo correcto es organizar la planilla de forma que eso no ocurra.
Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 27/09/2008

Si los numeros y fechas siguen un patron en la posicion, por ejemplo, cada seguna columna, puedes usar algo como esto:

=SUMAPRODUCTO(B2:G2,--(RESIDUO(COLUMNA(B2:G2),2)=0)), para columnas pares y

=SUMAPRODUCTO(B2:G2,--(RESIDUO(COLUMNA(B2:G2),2)=1)), para columnas nones

Galileogali -
Buenos Aires, Argent...
Escrito por Galileogali -
el 27/09/2008

Plantee el problema en MrExcel y acudieron nada menos que Barry Houdini,HotPepper y definitoriamente Aladin Akyurek.

Https://www.mrexcel.com/forum/showthread. Php? T=344027

 Desde ya que si el distingo puede ser pociional tenemos , por ejemplo la solucion de Armando. De todas maneras quiero aportar una pseudo solucion.   Particularmente la usaria si tuviera Una columna voluminosa y la certeza de un formato de fechas homomorfo (es decir similar en cuanto por ejemplo al separador "/" ò "-"

Paso 1 - Seleccionar la columna

Paso 2 - Datos >> Texto en columnas >> Delimitados >>Siguiente >> Siguiente >> Elegir "Texto", Finalizar

Paso 3 Uso Formula :(supongo rango en A1:A6

=SUMAPRODUCTO(NO(ESNUMERO(HALLAR("/";A1:A6)))*A1:A6)

o

=SUMAPRODUCTO(NO(ESNUMERO(HALLAR("-";A1:A6)))*A1:A6)

Tengo que probar que ocurriria con formato de fechas "dd.mm.yyyyy", en el supuesto de que el separador decimal coincidiera con ". ". Por ahora espero que eso no ocurra....

GALILEOGALI
https://excelgali.mejorforo.net/



 

Arturo Gómez
Mestrado em matemáticas universidade f...
Escrito por Arturo Gómez
el 28/09/2008

Bueno, en primer lugar tendrías que separar fechas de números, lo que no es automático  porque las fechas en excel SON números.   Entonces, vas a tener que encontrar una solución inteligente

El número 1 equivale a la fecha 1/1/1900, y el día de hoy equivale a 37819. Cabe la posibilidad que los números de tus fechas ocupen un rango numérico diferente a los números que no son fechas. Ahí puedes usar la condicion de mayr o menor para separar o sumar condicional.

De futuro, separar ambas columnas pues son conceptos diferentes

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 01/10/2008
Cesar, podemos cerrar el tema o necesitas otra opcion?
Escrito por Qrollo
el 21/10/2008

Hola necesito una formula que guarde un valor en una celda y cada que ponga un numero en otra celda me sume el valor ingresado en la anterior, por ejemplo tenemos la celda A1 donde quiero que se guarden los valores, si al capturar un 1 en la celda A2 se sume ese valor en A1, si yo vuelvo a ingresar otro uno en A2, ahora en la celda A1 ya no sea uno sino un 2; ahora en la celda A1 ya tenemos el valor 2 y si ingreso en A2 un 2, se sume el 2 que ingrese mas el 2 que ya estaba en A1 y el valor ya sea 4.

Creo que otra opcion seria que si diera un click en la celda A2 se sume el numero de clicks que di en dicha celda y se sumen en A1.

Se podra hacer eso?

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 21/10/2008
Sugiero iniciar nuevo tema
Escrito por Qrollo
el 22/10/2008
"Sugiero iniciar nuevo tema "
por Armando Montes (Octubre 2008)



quisiera ke me ayudara con mi problema :(
Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 22/10/2008

Si es posible pero para mejorar la posibilidad de recibir respuestas inicia un nuevo tema.

Ve a la primera pagina pagina del foro y ahi puedes hacerlo