En este grupo En todos

Foro de Excel



Comparar Celda Color y valor de formato

Escrito por Dan How
el 20/10/2007
Hola a todos los gurus de Excel. Tengo dos preguntas: 1) Tengo en la Celda A1 Una fecha: "15/10/2007", Coloqué en A2 Que fuera Igual a A1. Pero el formato lo cambié para que apareciera unicamente "Lunes" (el dia dddd )en ves de toda la fecha. Resulta que quiero un condicional en la celda A3 "=SI(A2="Lunes";0;1)". Pues sucede que Asi el valor de la celda sea lunes el condicional simpre va a dar falso... Por que? 2) Estoy ubicado en la celda C2 Y quiero un condicional para que si el valor de la celda A2 es igual a lunes entonces esta celda donde estoy ubicado sea de color verde. ¿Es decir hay alguna forma ce cambiar el formato de una celda, de marera condicional con respecto al valor de otra...? Por este motivo el formato condicional no me sirve por que necesito cambiar el formato de una celda con respecto al valor que contiene otra. GRACIAS A TODOS, DE ANTEMANO. Herman_Colombiano (-_-)

Ficheros adjuntos:
Celda
Javi Boa Do R
Matemáticas puras santiago de compostela
Escrito por Javi Boa Do R
el 20/10/2007

En la celda A3 debes poner: =si(diasem(A2)=2;0;1)

El motivo es que en A2 no hay lunes de contenido, sino la fecha que has puesto aunque en el formato ddd.

Mira la función diasem en la ayuda de excel.

Y sobre el formato condicional, sí te sirve: estando en C2 le das a formato condicional fórmula =diasem(A2)=2 y le defines el formato trama verde.

Salu2