En este grupo En todos

Foro de Excel



como operar matrices y aproximar de decimales a enteros

francisco
Ingenieria civil centro universitario ...
Escrito por Francisco Valenzuela Valenzuela Zetina
el 31/05/2008

1. - Quiero aprender a programar y operar matrices de 2, 3, 4, 5, 6,...... N columnas por determinadas (Xi) filas, se usa generalmente para calcular areas de terrenos donde tenemos dos columnas (X, Y) y un terminado número de filas, las cuales pueden ser 15, 20 30, 150, etc. Por ejemplo:  

   

X Y
250 235
325 456
125 845
500 123
600 523
125 125
34 250
45 234

Cuyo resultado es

Area = X*Y - Y*X = 39940 Mts.²

2. - Lo otro, como aproximar una cantidad decimal a entero si es mayo o menor de 0. 5, por ejemplo:

5. 78 = 6, pues el decimal es mayor que punto cinco.

8. 4 = 8, pues el decimal es menor que punto cinco.


Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 31/05/2008

Hola Francisco, para lo primero puedes intentarlo con SUMAPRODUCTO, en este link tengo un ejemplo:

www.geocities.com/excelmx/SUMPARODUCTO. Xls

Para lo segundo puedes usar algo asi:

=REDONDEAR(5. 78,1), en vez de 5. 78 puedes usar referencia a una celda:

=REDONDEAR(A1,1), en este link hay mas explicaciones, suerte

Https://office.microsoft.com/es-es/excel/HP100705183082. Aspx? Pid=CH100793493082