En este grupo En todos

Foro de Algoritmos



ayuda con este algoritmo

josue mauricio
Valle del Cauca, Col...
Escrito por Josue Mauricio Hurtado Mosquera
el 05/11/2009

Hola a todos

Me podrian a ayudar hacer el algoritomo de determinar si un numero es primo y dado un valor determinado hacer una suma entre ellos

Gracias por la atencion prestada

Keyvers Mari
Miranda, Venezuela
Escrito por Keyvers Mari
el 31/01/2010

Se desea diseñar un algoritmo para saber si un número es primo o no.
Un número es primo si sólo puede dividirse por sí mismo y por la unidad (es decir, no tiene más divisores
que él mismo y la unidad). Por ejemplo, 9,8,6,4, 12, 16,20, etc. , no son primos, ya que son divisibles
por números distintos a ellos mismos y a la unidad. Así, 9 es divisible por 3, 8 lo es por 2, etc. El
algoritmo de resolución del problema pasa por dividir sucesivamente el número por 2, 3,4... , etc.
1. Inicio.
2. Poner X igual a 2 (X = 2, X variable que representa a los divisores del
3. Dividir N por X (N/X).
4. Si el resultado de N/X es entero, entonces N no es un número primo y
5. Suma 1 a X (X c X + 1).
número que se busca N).
bifurcar al punto 7; en caso contrario, continuar el proceso.

6. Si X es igual a N, entonces N es un número primo; en caso contrario,
7. Fin.
bifurcar al punto 3.
Por ejemplo, si N es 13 1, los pasos anteriores serían:
1. Inicio.
2. X = 2.
3. 131/X. Como el resultado no es entero, se continúa el proceso.
5. X t 2 + 1, luego X = 3.
6. Como X no es 131, se bifurca al punto 3.
3. 131/X resultado no es entero.
5. X t 3 + 1, x = 4.
6. Como X no es 131 bifurca al punto 3.
3. 131/X... , etc.
7. Fin.

Jose Palmeros
Ingeniero en desarrollo de software un...
Escrito por Jose Palmeros
el 26/02/2011

/*

*/



Algoritmo NumPrimo


Var

.... Int Numprimo


Inicio

... Pantalla "Ingresa un número"

... Leer Numprimo

.... Si (Oyes tu eres primo) {

........ Si lo soy

........ Ah, ok, pasas

........ Pantalla "Este si es primo"

.... SiNo

........ No soy primo y que te importa

........ Pantalla "Este wey no es primo ¿Que hacemos con el?"

.... FinSi

Escrito por Eduardo Javier Perez Cenepo
el 10/06/2011

Para hacer un algoritmo que identifique que un numero es primo procederemos en este caso a usar PSEUDOCODIGO EN ESPAÑOL:
"" los numeros son primos si y solo si son enteros positivos diferentes de 1, y si tienen solo 2 divisores. ""

INICIO
VAR:
cont, numero, contdiv : ENTEROS
HACER
LEER numero
MIENTRAS( numero<=1)
cont= 1, contdiv=0
HACER
SI ( numero mod cont) ENTONCES
contdiv= contdiv+1
FIN_SI
cont=cont+1
MIENTRAS (cont <=numero)

SI ( contdiv = 2) ENTONCES
MOSTRAR numero "es primo"
SI_NO
MOSTRAR numero "no es primo"
FIN_SI
FIN