En este grupo En todos

Foro de Excel



Agregar espacios en blanco en una celda de excel

CLAUDIA PATRICIA
Baja California, Méx...
Escrito por Claudia Patricia R.a.
el 03/01/2012

Hola, que tal
Tengo una A con datos y una celda en B Blanco, sin embargo la celda B no debe ser mayor ni menor a 71 caracteres.
Mi pregunta es como puedo llenar el espacio en blanco de la diferencia cuando se pone un dato, por ejemplo:

A La celda B, se le captura lo siguiente:
NOMINA
solo son 6 caracteres, le hacen faltan 65 caracteres para completar y no se como llenar la formula, ya que esta la concatenacion.

=celda A&celdaB(extrae,1,71)
si se pasa de 71 caracteres si me los quita pero si le faltan no se como agregar los que le faltan, espero haberme explicado. Gracias.

Robert Gunn
Ing. de sistemas unmsm
Escrito por Robert Gunn
el 04/01/2012

Claudia, asumiendo que tu contenido está en la celda A1, para rellenar con espacios vacíos hasta llegar a 71 caracteres pones lo siguiente:

=SI(LARGO(A1)<71,A1&REPETIR(" ",71-LARGO(A1)))

Para controlar ambos caso (si se pasa o si falta), lo aumentas a tu fórmula con una condicional

Saludos.

Cacho Rodríguez
Ing. electrónica u.n.r.
Escrito por Cacho Rodríguez
el 05/01/2012

Hola! Claudia (y Robert).
Si tu texto estuviese en A1, también podrías intentar esta otra alternativa:

= IZQUIERDA( A1 & REPETIR(" "; 71); 71)

Saludos, Cacho R.

Claudia Patricia R.a.
Baja California, Méx...
Escrito por Claudia Patricia R.a.
el 06/01/2012

Muchas, gracias, cualquiera de las 2 fórmulas me funciona muy bien, Gracias por ayudarme a despejar esta duda.