En este grupo En todos

Foro de Excel

sacar promedio

jorge
Bogotá, Colombia
Escrito por Jorge Prada
el 30/04/2007

Como hago para sacar el promedio en una lista de varias prsonas, una por una,

Tengo varias personas con unas cantidades, estan ordenadas por nombre pero como hago para hacer una macro que tome las cantidades persona por persona y les saque el promedio.

Gracias

Luis T..
Ecuador, Ecuador
Escrito por Luis T..
el 30/04/2007

Lo puedes hacer sin necesidad d

Te recomiendo que uses Subtotales (Datos / Subtotales), para cada cambio en Nombre, use la función Promedio, Agregar Subtotal a: seleccionas la columna que contiene las cantidades de las cuales deseas sacar el promedio y listo!

Saludos,

 

Sorenkierkegaard
Finlandia del Sur - ...
Escrito por Sorenkierkegaard
el 30/04/2007

Tambien puedes utilizar tablas dinámicas ó la siguiente fórmula:

=(SUMAR. SI(D9:D21,"SOREN",E9:E20))/CONTAR. SI(D9:D20,"SOREN")

Jorge Prada
Bogotá, Colombia
Escrito por Jorge Prada
el 01/05/2007
Gracias, realmente no pense que me fueran a contestar voy a probar a ver como me va  y nuevamente gracias
Lalo
Jalisco, México
Escrito por Lalo
el 04/03/2008

Hola

Como saco el promedio de una tabla la cual tiene celdas con valores = o. Me han dicho de una formula que dice algo de. Promedio( si( etc etc etc...

La he probado y aplicado pero no me funciona.. Necesito activar alguna funcion primero o que... He usado otra quie dice algo como suma(si.... Contar(si.. Etc etc... Pero nada tampoco.

Lo que quiero es sacar el promedio de una serie de datos y que no me tome los valores = o.... Espero me ayuden.. Gracias

Jorge Prada
Bogotá, Colombia
Escrito por Jorge Prada
el 04/03/2008
52 =SI(A1=0;" ";A1)
32 =SI(A2=0;" ";A2)
0 =SI(A3=0;" ";A3)
25 =SI(A4=0;" ";A4)
25 =SI(A5=0;" ";A5)
25 =SI(A6=0;" ";A6)
0 =SI(A7=0;" ";A7)
0 =SI(A8=0;" ";A8)
0 =SI(A9=0;" ";A9)
=PROMEDIO(A1:A9) =PROMEDIO(B1:B9)

Puedes utilizar otra columna y en donde valides, que las celdas con valor cero te queden vacias y asi puedes sacar promedio a tus valores.

Espero t sirva


Robertj
Holanda
Escrito por Robertj
el 04/03/2008

Como puedo hacer para sacar un promedio semanal de 31 columnas,  les agradecere me ayuden con esto. 


Gracias de antemano

Escrito por Isabella
el 31/03/2008
Hola como  puedo sacar un promedio?
Escrito por Carolina
el 08/10/2008
Primero sumamos luego dividimos entre la cantidad de numeros que hayamos sumado
Marco Nicoletti
Santiago, Chile
Escrito por Marco Nicoletti
el 08/01/2010

Hola, necesito aclarar la siguiente duda, he buscado en todas partes pero no encuntro uan solucion bastante clara, lo que pasa que realizé en visual basic un userform que es una encuesta para evaluar el estado de puntos de venta, donde existe una escala de muy malo, malo, regular, bueno, muy bueno, todos estos datos son copiados a una planilla de excel cada vez qeu se responde la encuesta, el tema es el siguiente, de todo esto necesito obtener una nota final de cada punto de venta, y en una parte de la planilla realizé uan formula de =si(... En caso de cada item evaluado sea bueno malo smuy bueno... Donde las notas van de 1 a 5, y depues en la columna (primera celda) de donde dice Evaluacion Final, puse uan formual de promedio de estas notas, el sistema funciona fantastico pero solo para la primera encuesta contestada, y necesito qeu esto se vaya rellenando a medida que se ingresan a la encuesta distintos puntos de ventas con distitnas evaluaciones, muchas gracias! Oajal me puedan ayudar.

Saludos,

Marco

Cacho Rodríguez
Ing. electrónica u.n.r.
Escrito por Cacho Rodríguez
el 08/01/2010

Marco:
Has incorporado tu pregunta a un debate iniciado hace -casi- 3 años.

Te sugiero que a través del siguiente enlace: Crear un debate , des inicio a un debate nuevo.

De ese modo los foristos actuales podrán leer tu inquietud y darte algún tipo de soporte.
Saludos, Cacho.

Cacho Rodríguez
Ing. electrónica u.n.r.
Escrito por Cacho Rodríguez
el 08/01/2010

Quizás sea tiempo de cerrar este debate...