En este grupo En todos

Foro de Excel

redondeo numeros enteros

PEDRO
Jaén, España
Escrito por Pedro Lopez Quesada
el 04/01/2008

Hola Sr. Abraham

Puedo redondear un numero entero   ej: 3240  ir al 3200  y 3273 ir a 3300

Gracias

Luis De La Cabada Monroy
Contador publico esca ipn, tepepan
Escrito por Luis De La Cabada Monroy
el 04/01/2008

Hola Pedro:

Utiliza la función REDONDEAR, en número de decimales ponle -2.

Saludos

Pedro Lopez Quesada
Jaén, España
Escrito por Pedro Lopez Quesada
el 04/01/2008

Perdón, no se si me explique bien, no son números decimales, son enteros sin decimal.

Ej  (1245)   mil doscientos cuarenta y cinco redondear a la baja por que no llega a 50 y quisiera redondear a mil: doscientos (1200)  ó  1273 redondear a la alza porque excede de 50 y seria mil trescientos. (1300)

Saludos.


Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 05/01/2008

La funcion que te dice Luis hace CON ENTEROS lo que necesitas:

=REDONDEAR(A2,-2)

Viajero
Badajoz, España
Escrito por Viajero
el 05/01/2008

Hola

Gracias a vuestros comentarios he aprendido a redondear. Pero os consulto una vuelta de tuerca más. Un par de consultas:

* 1. - Como el redondeo es por aproximación. Si redondeas a números enteros convertirá 3. 2 en 3 y 3. 7 en 4. ¿Se puede configurar para redondear todo al alza o la baja? ¿O introducir que hasta 1. 1 redondee a la baja y a partir de ahí al alza?

* 2.- ¿Puedo en una tabla hacer diferentes criterios de redondeos? Que todos los resultados superiores a 10 € redondeen a números enteros, y que los inferiores redondeen a 0. 50€. Por ejemplo; Si me sale 12. 60 € redondee a 13 €, pero si sale 8. 60 € redondee a 8. 50 €. Lo veo complicado, pero el caso es que con el antiguo basic usando los "let" e "input" se podría hacer.

Saludos y gracias.





Viajero
Badajoz, España
Escrito por Viajero
el 05/01/2008
Creo que la fórmula del redondeo funciona del siguiente modo. Si pones (a1,2) te redondea las cifras decimales y si pones (a1,-2) te redondea cifras enteras. Positivo para decimales y negativo para enteros.
Pedro Lopez Quesada
Jaén, España
Escrito por Pedro Lopez Quesada
el 05/01/2008

Perdon, tema cerrado, no entendí lo del -2

Gracias y perfecto. Perdón Luis por no entenderlo lo del signo negativo.


Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 06/01/2008
Cerrado por Pedro