En este grupo En todos

Foro de Excel

Formula para calculo antiguedad

Escrito por Rafael Fernandez
el 17/09/2009

Necesito si me pueden ayudar con una fórmula para sacar la antiguedad de un trabajador para calcular indemnización por despido conforme siguiente criterio: "En los casos de despido dispuesto por el empleador sin justa causa, habiendo o no mediado preaviso, éste deberá abonar al trabajador una indemnización equivalente a UN (1) mes de sueldo por cada año de servicio o fracción mayor de TRES (3) meses, tomando como base la mejor remuneración mensual, normal y habitual devengada durante el último año o durante el tiempo de prestación de servicios si éste fuera menor."
Es decir, tengo que computar un año de antiguedad por cada año de servicio o fracción mayor de 3 meses (la dificultad se me está presentando en esta última parte).
Les agradezco la colaboración.

Armando Montes
Foro excel emagister
Escrito por Armando Montes
el 17/09/2009

Considerando años de 365 dias esta es una formula sencilla:
=REDONDEAR(B25-B26)/365+0. 25,0)
Si requieres mayor precision usa SIFECHA.

Carlos Martínez Zaragoza
Maestria en finanzas empresariales uni...
Escrito por Carlos Martínez Zaragoza
el 18/09/2009

Debido a que esta función es poco conocida, normalmente se calcula el número de días transcurridos entre la fecha de hoy y la fecha de nacimiento y se divide entre 365. 25, pero el resultado no siempre es exacto.

o bien utilice esta función: =SIFECHA() de la siguiente forma:

  • Para calcular la edad en años : =SIFECHA(fecha_de_nacimiento,fecha_de:hoy,"y")

  • Para calcular los meses: =SIFECHA(fecha_de_nacimiento,fecha_de:hoy,"ym")

  • Para calcular los días: =SIFECHA(fecha_de_nacimiento,fecha_de:hoy,"md")

La fórmula completa sería juntando los tres elementos así:

=SIFECHA(A2,B2,"y")&" años, "&SIFECHA(A2,B2,"ym")&" meses y "&SIFECHA(A2,B2,"md")&" días"

3. - o bien, escriba esta fórmula (suponemos que la fecha de nacimiento se encuentra en A2).


POdrias entrar a esta direccion a ver mas la explicacion: http://www.ofisol.com. Mx/excel/Funcion14. Htm

Escrito por Rafael Fernandez
el 18/09/2009
"Considerando años de 365 dias esta es una formula sencilla:
=REDONDEAR(B25-B26)/365+0. 25,0)
Si requieres mayor precision usa SIFECHA.
"

por Armando Montes (Septiembre 2009)

Muchísimas gracias por tu aporte, me resul

Escrito por Kiky 24
el 11/10/2009
"Debido a que esta función es poco conocida, normalmente se calcula el número de días transcurridos entre la fecha de hoy y la fecha de nacimiento y se divide entre 365. 25, pero el resultado no siempre es exacto.

o bien utilice esta función: =SIFECHA() de la siguiente forma:
  • Para calcular la edad en años : =SIFECHA(fecha_de_nacimiento,fecha_de:hoy,"y")

  • Para calcular los meses: =SIFECHA(fecha_de_nacimiento,fecha_de:hoy,"ym")

  • Para calcular los días: =SIFECHA(fecha_de_nacimiento,fecha_de:hoy,"md")

La fórmula completa sería juntando los tres elementos así:
=SIFECHA(A2,B2,"y")&" años, "&SIFECHA(A2,B2,"ym")&" meses y "&SIFECHA(A2,B2,"md")&" días"

3. - o bien, escriba esta fórmula (suponemos que la fecha de nacimiento se encuentra en A2).


POdrias entrar a esta direccion a ver mas la explicacion: http://www.ofisol.com. Mx/excel/Funcion14. Htm

"

por carlos (Septiembre 2009)




Muchas gracias me sivio mucho ami tambien Edith Muñix

Maria Bueno
Apure, Venezuela
Escrito por Maria Bueno
el 10/12/2009

Necesito calcular las prestaciones sociales

Escrito por Roberto Antonio Perez Tornell
el 28/12/2010

Maestro eres un FREGONAZO
Estaba enfrascado en ese punto del cálculo de antigüedad y solo lo lograba como fecha fraccionada, ni hablar el que sabe sabe, MUCHAS GRACIAS

Cacho Rodríguez
Ing. electrónica u.n.r.
Escrito por Cacho Rodríguez
el 28/12/2010

Gracias, Roberto, por tu devolución.
Saludos, Cacho.