Home > Foro de Excel >

Debates de Excel

> Enumerar Filas
Foro de Excel
Foro de Excel
4 Cursos online | 22545 Debates | 4683 Documentos | 21 Vídeos | 2 Test | 2 Blogs | 723 Imágenes | 39598 Miembros

Enumerar Filas

vihura
La Rioja, Argentina
Escrito por Vihura Ramirez el 25/02/2010

Hola a Todos:

En una hoja, tengo las siguientes formulas:


A1

=SI(B1<>"";1;"")

A2

=SI(B2<>"";A1+1;"")

De esta manera funciona bien, es decir a medida que ingreso datos desde B1, en la columna A, en forma automática se numeran las filas en forma correlativa, 1,2,3,4,5 etc. , el problema es cuando por cualquier cuestión borro un dato de la B:B, las que continúan (filas), después de la borrada, aparece el mensaje de error # ¡VALOR! , este error lo comprendo, pues no encuentra un valor para seguir la suma indicada desde la celda A2, lo que necesito es como evitar esto, que si ocurre un borrado de un dato dentro de la columna B:B, la numeración se acomode de forma inmediata, espero haber sido claro.


Será hasta una próxima.

Saludos


Vihura

compartir


Arnaldo Torres
Central, Paraguay
Escrito por Arnaldo Torres el 25/02/2010

Hola Vihura...


En las filas siguientes a la primera formula en vez de


=SI(B2<>"";A1+1;"") reemplazalo por =SI(B2<>"";MAX(A$1:A1)+1;"")




Saludos..




Cacho Rodríguez
Ingeniería electrónica universidad nac...
Escrito por Cacho Rodríguez el 25/02/2010

Hola! Vihura. Desde [A1] hacia abajo podrías intentar con:

= SI( B1 = ""; ""; CONTARA(B$1:B1) )

Saludos, Cacho.


Vihura Ramirez
La Rioja, Argentina
Escrito por Vihura Ramirez el 26/02/2010

Hola a ambos:

Bueno antes que nada, agradecerles en primera instancia por sus respuestas, las mismas funcionan bastante bien, pero me queda la fila en blanco, aunque la numeración continua, eso está perfecto, pero como hago para que las otras líneas con la numeración, se desplacen una hacia arriba, sería algo como reeemplazar a la borrada, espero se me interprete lo que necesito, una parte estaría solucionada, faltaría la otra.

Saludos.


Vihura


Cacho Rodríguez
Ingeniería electrónica universidad nac...
Escrito por Cacho Rodríguez el 26/02/2010

Amigo Vihura:
Borrar y/o eliminar una fila son dos cosas totalmente distintas...

Con la fórmula que te mostré, si eliminas una fila: la columna A se re-numera automáticamente y toda la información "sube" una fila.

Y si borras la información de una celda de la columna B: la celda correspondiente de la columna A no toma valor pero sí lo hacen las subsiguientes.

Si ésto no es el efecto pedido entonces tendrás que explicarte mejor.
Saludos, Cacho.


Vihura Ramirez
La Rioja, Argentina
Escrito por Vihura Ramirez el 26/02/2010

Hola Cacho, tu observación es muy positiva, existe la diferencia entre borrar un dato de una celda a borrar una fila, si funciona el efecto, me quedaría como crear una macro que me borrara la fila, donde me encuentre en ese momento, por ej. Si me ubico en una celda cualquiera de la fila a borrar, con un atajo del teclado, hacer correr la macro para que efectué la eliminación de la misma. Bueno me gustaría una última opinión tuya al respecto, y nuevamente darte las gracias desde La Rioja Maestro. Saludos.


Vihura


Vihura Ramirez
La Rioja, Argentina
Escrito por Vihura Ramirez el 26/02/2010

Hola Cacho, tu observación es muy positiva, existe la diferencia entre borrar un dato de una celda a borrar una fila, si funciona el efecto, me quedaría como crear una macro que me borrara la fila, donde me encuentre en ese momento, por ej. Si me ubico en una celda cualquiera de la fila a borrar, con un atajo del teclado, hacer correr la macro para que efectué la eliminación de la misma. Bueno me gustaría una última opinión tuya al respecto, y nuevamente darte las gracias desde La Rioja Maestro. Saludos.


Vihura


Cacho Rodríguez
Ingeniería electrónica universidad nac...
Escrito por Cacho Rodríguez el 26/02/2010

Asocia un atajo de teclado a lo siguiente:

Sub EliminarFilaActiva
Activecell.EntirerRow.delete
End Sub

Fíjate si te sirve...
Saludos, Cacho


Cacho Rodríguez
Ingeniería electrónica universidad nac...
Escrito por Cacho Rodríguez el 02/03/2010

 
Páginas internacionales: España  |  Italia  |  Francia  |  México  |  Alemania  |  Reino Unido  |  Argentina  |  Chile  |  Colombia  |  USA |  India |  Y próximamente: Brasil | 

Búsquedas frecuentes: oratane escribir en mayuscula psicologia paint runner que es un vale como agregar musica al power point

EMAGISTER Servicios de formación, S.L. Copyright 1999/2013.